srelay bind to device (#2193)
[openwrt/svn-archive/archive.git] / net / igmpproxy / Makefile
index 8bf9d20e7cbfb181b42015ad788c1742db10fc76..4fa9cf1c28ec4f5583258cb50ea3e706d43f836e 100644 (file)
@@ -42,10 +42,10 @@ define Build/Compile
 endef
 
 define Package/igmpproxy/install       
-       install -d -m0755 $(1)/etc
-       install -m0755 $(PKG_BUILD_DIR)/src/igmpproxy.conf $(1)/etc
-       install -d -m0755 $(1)/usr/sbin $(1)/etc
-       install -m0644 $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/igmpproxy.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,igmpproxy))