[net] Routing and Redirection: Moved IGMP Routing Daemon to Routing and Redirection...
[openwrt/svn-archive/archive.git] / net / igmpproxy / Makefile
index 97f79682b8dadfbcdd880bde7055d6b04df6e5fa..b420fc5629b9f435444bd7ff71120dab384391eb 100644 (file)
@@ -1,50 +1,53 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=igmpproxy
-PKG_VERSION:=0.1-beta2
-PKG_RELEASE:=1
+PKG_VERSION:=0.1
+PKG_RELEASE:=2
 
-PKG_SOURCE:=$(PKG_NAME)-src-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/igmpproxy
-PKG_MD5SUM:=2a5a59480f44d4b14077a6b5319e9940
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_MD5SUM:=c56f41ec195bc1fe016369bf74efc5a1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/igmpproxy
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Multicast Routing Daemon
-  DESCRIPTION:=\
-       IGMPproxy is a simple dynamic Multicast Routing Daemon using \\\
-       only IGMP signalling (Internet Group Management Protocol).
   URL:=http://sourceforge.net/projects/igmpproxy
 endef
 
+define Package/igmpproxy/description
+       IGMPproxy is a simple dynamic Multicast Routing Daemon using
+       only IGMP signalling (Internet Group Management Protocol).
+endef
+
 define Package/igmpproxy/conffiles
 /etc/igmpproxy.conf
 endef
 
-define Build/Compile   
+TARGET_CFLAGS += -Dlog=igmpproxy_log
+
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)"
+               CFLAGS="$(TARGET_CFLAGS) -std=gnu99"
 endef
 
-define Package/igmpproxy/install       
+define Package/igmpproxy/install
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy.conf $(1)/etc
-       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc
+       $(INSTALL_CONF) ./files/igmpproxy.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/igmpproxy.init $(1)/etc/init.d/igmpproxy
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/igmpproxy $(1)/usr/sbin/
 endef