ipcad fixes:
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index 159b0f5a70fad18994890c4e14a0f4ece4e4935b..0f3a56063364b2e72f90adca4a840a11974f99b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
-PKG_VERSION:=3.7
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ipcad
-PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,17 +23,20 @@ define Package/ipcad
   CATEGORY:=Network
   DEPENDS:=+libpcap
   TITLE:=listens for traffic on the specified interfaces
-  DESCRIPTION:=\
-       This daemon listens for traffic on the specified interfaces.\\\
-       It has the built-in RSH and NetFlow engines to allow exporting \\\
-       the accounting data the same way as Cisco routers do.
   URL:=http://lionet.info/ipcad/
 endef
 
+define Package/ipcad/description
+       This daemon listens for traffic on the specified interfaces.
+       It has the built-in RSH and NetFlow engines to allow exporting
+       the accounting data the same way as Cisco routers do.
+endef
+
 define Package/ipcad/conffiles/
 /etc/ipcad.conf
 endef
 
+# XXX: don't detect/use netfilter ipq capture
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                cfglex.c \
@@ -52,6 +51,7 @@ define Build/Configure
                , \
                ac_cv_func_getifaddrs=no \
                ac_cv_header_ifaddrs_h=no \
+               ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
        )
 endef
 
@@ -62,10 +62,10 @@ define Build/Compile
 endef
 
 define Package/ipcad/install   
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ipcad))