nginx: Add openssl dependency. Also fix parallel build.
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index 0f3a56063364b2e72f90adca4a840a11974f99b2..125cce046031d396db3ee8897c78442deedef4aa 100644 (file)
@@ -1,21 +1,22 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
 PKG_VERSION:=3.7.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ipcad
 PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ipcad
@@ -36,32 +37,21 @@ define Package/ipcad/conffiles/
 /etc/ipcad.conf
 endef
 
-# XXX: don't detect/use netfilter ipq capture
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               cfglex.c \
-               cslex.c \
-       );
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --disable-static \
-               --with-psrc=pcap \
-               --with-pcap-include="$(STAGING_DIR)/usr/include" \
-               --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
-               , \
-               ac_cv_func_getifaddrs=no \
-               ac_cv_header_ifaddrs_h=no \
-               ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/ipcad/install   
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --disable-static \
+       --with-psrc=pcap \
+       --with-pcap-include="$(STAGING_DIR)/usr/include" \
+       --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
+
+# XXX: don't detect/use netfilter QUEUE/ULOG captures
+CONFIGURE_VARS += \
+       ac_cv_func_getifaddrs=no \
+       ac_cv_header_ifaddrs_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
+
+define Package/ipcad/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin