peerguardian: Fix typo
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index b2f2504f8c9f9eccaf41e7740d379807ad6541ee..125cce046031d396db3ee8897c78442deedef4aa 100644 (file)
@@ -1,24 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
-PKG_VERSION:=3.7
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ipcad
-PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
-PKG_CAT:=zcat
+PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,7 +29,7 @@ endef
 
 define Package/ipcad/description
        This daemon listens for traffic on the specified interfaces.
-       It has the built-in RSH and NetFlow engines to allow exporting 
+       It has the built-in RSH and NetFlow engines to allow exporting
        the accounting data the same way as Cisco routers do.
 endef
 
@@ -40,34 +37,25 @@ define Package/ipcad/conffiles/
 /etc/ipcad.conf
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); touch \
-               cfglex.c \
-               cslex.c \
-       );
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --disable-static \
-               --with-psrc=pcap \
-               --with-pcap-include="$(STAGING_DIR)/usr/include" \
-               --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
-               , \
-               ac_cv_func_getifaddrs=no \
-               ac_cv_header_ifaddrs_h=no \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/ipcad/install   
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --disable-static \
+       --with-psrc=pcap \
+       --with-pcap-include="$(STAGING_DIR)/usr/include" \
+       --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
+
+# XXX: don't detect/use netfilter QUEUE/ULOG captures
+CONFIGURE_VARS += \
+       ac_cv_func_getifaddrs=no \
+       ac_cv_header_ifaddrs_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
+
+define Package/ipcad/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ipcad))