aMule: update to 2.3.1
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index edc5ac9f6406a9078830fac4ac4a939f79b709a3..14143a1292772e266f4c2b192d2d4822937bf08d 100644 (file)
@@ -1,63 +1,63 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
-PKG_VERSION:=3.7
-PKG_RELEASE:=1
-PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=3
 
-PKG_SOURCE_URL:=@SF/ipcad
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/ipcad
+PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ipcad
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap
+  DEPENDS:=+libpcap $(LIBRPC_DEPENDS) +libpthread
   TITLE:=listens for traffic on the specified interfaces
-  DESCRIPTION:=This daemon listens for traffic on the specified interfaces.\\\
-It has the built-in RSH and NetFlow engines to allow exporting\\\
-the accounting data the same way as Cisco routers do.\\\
   URL:=http://lionet.info/ipcad/
 endef
 
+define Package/ipcad/description
+       This daemon listens for traffic on the specified interfaces.
+       It has the built-in RSH and NetFlow engines to allow exporting
+       the accounting data the same way as Cisco routers do.
+endef
+
 define Package/ipcad/conffiles/
 /etc/ipcad.conf
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --disable-static \
+       --with-psrc=pcap \
+       --with-pcap-include="$(STAGING_DIR)/usr/include" \
+       --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-shared \
---disable-static \
---disable-rpath \
---with-gnu-ld \
---with-psrc=pcap \
---with-pcap-include="$(STAGING_DIR)/usr/include" \
---with-pcap-libraries="$(STAGING_DIR)/usr/lib",touch cfglex.c cslex.c;)
-endef
+# XXX: don't detect/use netfilter QUEUE/ULOG captures
+CONFIGURE_VARS += \
+       ac_cv_func_getifaddrs=no \
+       ac_cv_header_ifaddrs_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
-endef
+TARGET_LDFLAGS += $(LIBRPC)
 
-define Package/ipcad/install   
-       install -d -m0755 $(1)/etc
+define Package/ipcad/install
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ipcad))