i2c-tools: make the python dependency optional
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index 3ab60fb2ecb2fc0bbdf34be0ced28559be1f2550..1d541f90387c0c38c4ea68e4801ae0846b42715c 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,12 +15,14 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/ipcad
 PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/ipcad
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap
+  DEPENDS:=+libpcap $(LIBRPC_DEPENDS)
   TITLE:=listens for traffic on the specified interfaces
   URL:=http://lionet.info/ipcad/
 endef
@@ -50,13 +51,9 @@ CONFIGURE_VARS += \
        ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
        ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+TARGET_LDFLAGS += $(LIBRPC)
 
-define Package/ipcad/install   
+define Package/ipcad/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/bin