[PATCH 2/4] packages/lang/php5: Remove uts domain patch
[openwrt/svn-archive/archive.git] / net / ipcad / Makefile
index 28ba31c3e379e848c7be5c53239f7cb557ad5958..eeb4b172fe494cb9994f60ef882fa3f6a0b88ea6 100644 (file)
@@ -1,23 +1,19 @@
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
-PKG_VERSION:=3.7
-PKG_RELEASE:=1
-PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=3
 
-PKG_SOURCE_URL:=@SF/ipcad
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/ipcad
+PKG_MD5SUM:=125605249958894148ec26d3c88189f5
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,46 +22,44 @@ define Package/ipcad
   CATEGORY:=Network
   DEPENDS:=+libpcap
   TITLE:=listens for traffic on the specified interfaces
-  DESCRIPTION:=This daemon listens for traffic on the specified interfaces.\\\
-       It has the built-in RSH and NetFlow engines to allow exporting\\\
-       the accounting data the same way as Cisco routers do.\\\
   URL:=http://lionet.info/ipcad/
 endef
 
+define Package/ipcad/description
+       This daemon listens for traffic on the specified interfaces.
+       It has the built-in RSH and NetFlow engines to allow exporting
+       the accounting data the same way as Cisco routers do.
+endef
+
 define Package/ipcad/conffiles/
 /etc/ipcad.conf
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --disable-static \
+       --with-psrc=pcap \
+       --with-pcap-include="$(STAGING_DIR)/usr/include" \
+       --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
 
-define Build/Configure
-       $(call Build/Configure/Default,--enable-shared \
-               --disable-static \
-               --disable-rpath \
-               --with-gnu-ld \
-               --with-psrc=pcap \
-               --with-pcap-include="$(STAGING_DIR)/usr/include" \
-               --with-pcap-libraries="$(STAGING_DIR)/usr/lib", \
-               touch cfglex.c cslex.c; \
-               ac_cv_func_getifaddrs=no \
-               ac_cv_header_ifaddrs_h=no \
-)
-endef
+# XXX: don't detect/use netfilter QUEUE/ULOG captures
+CONFIGURE_VARS += \
+       ac_cv_func_getifaddrs=no \
+       ac_cv_header_ifaddrs_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ip_queue_h=no \
+       ac_cv_header_linux_netfilter_ipv4_ipt_ULOG_h=no \
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -DHAVE_PCAP_H=1 -I$(STAGING_DIR)/usr/include" \
-               LIBS="-lnsl -pthread -lpcap" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
 define Package/ipcad/install   
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/ipcad.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ipcad $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,ipcad))