Update ipkungfu to 0.6.1 (#3626)
[openwrt/svn-archive/archive.git] / net / ipkungfu / Makefile
index 3120a3b9506c6791b11e92db2eddcd9e929c0b97..3a981d04843d8d50bdd7986e47cd0da010970eab 100644 (file)
@@ -1,22 +1,20 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipkungfu
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipkungfu
-PKG_VERSION:=0.6.0
+PKG_VERSION:=0.6.1
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=http://www.linuxkungfu.org/ipkungfu
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=a65b5e629a7e9ef00aaf20587d918e5f
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://www.linuxkungfu.org/ipkungfu
+PKG_MD5SUM:=89f6bc0df356dd4ee650882c54ec9074
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,11 +22,14 @@ define Package/ipkungfu
   SECTION:=net
   CATEGORY:=Network
   TITLE:=IPKungFu is an iptables-based Linux firewall
   SECTION:=net
   CATEGORY:=Network
   TITLE:=IPKungFu is an iptables-based Linux firewall
-  DESCRIPTION:=\
-       IPKungFu is an iptables-based Linux firewall.\\\
-       It aims to simplify the configuration of Internet\\\
-       connection sharing, port forwarding, and packet filtering.
-  URL:=http://www.linuxkungfu.org
+  URL:=http://www.linuxkungfu.org/
+  SUBMENU:=firewall
+endef
+
+define Package/ipkungfu/description
+       IPKungFu is an iptables-based Linux firewall.
+       It aims to simplify the configuration of Internet
+       connection sharing, port forwarding, and packet filtering.
 endef
 
 define Package/ipkungfu/conffiles
 endef
 
 define Package/ipkungfu/conffiles
@@ -46,18 +47,19 @@ define Package/ipkungfu/conffiles
 /etc/ipkungfu/vhosts.conf
 endef
 
 /etc/ipkungfu/vhosts.conf
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
+# uses GNU configure
 
 define Build/Compile
 
 define Build/Compile
-$(call Build/Compile/Default,all)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
 endef
 
 define Package/ipkungfu/install        
 endef
 
 define Package/ipkungfu/install        
-       mkdir -p $(1)/usr/sbin $(1)/etc/ipkungfu/
-       $(CP) $(PKG_BUILD_DIR)/dummy_server $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ipkungfu $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/dummy_server $(1)/usr/sbin/
+       $(CP) $(PKG_BUILD_DIR)/ipkungfu $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/ipkungfu/
        $(CP) $(PKG_BUILD_DIR)/files/conf/* $(1)/etc/ipkungfu/
 endef
 
        $(CP) $(PKG_BUILD_DIR)/files/conf/* $(1)/etc/ipkungfu/
 endef