[net] Firewall: Renamed firewall submenu to Firewall.
[openwrt/svn-archive/archive.git] / net / iptables-snmp / Makefile
index 0cadb4d71de8a5edbae02c733f1baddf40d591cc..4e3cd2b3ede31b4b2f295180638e13ed3ca4fbdb 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,19 +14,16 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nobiscuit.com/iptables-snmp
 PKG_MD5SUM:=8370d2f0c899461a053da491400119d1
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/iptables-snmp
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+snmpd
+  DEPENDS:=+snmpd +libiptc
   TITLE:=An snmpd plugin to access iptables rules
   URL:=http://www.nobiscuit.com/iptables-snmp/
+  SUBMENU:=Firewall
 endef
 
 define Package/iptables-snmp/description
@@ -37,6 +33,7 @@ endef
 define Build/Compile   
        $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all install \
        )
 endef