Fix/clean several hundred package makefiles
[openwrt/svn-archive/archive.git] / net / iptables-snmp / Makefile
index dfb243c50c46aa645790b84fb3379d36610a1d9c..eaa6b2f405fd9dfda3dce9995264a0d62c6d4e99 100644 (file)
@@ -30,16 +30,11 @@ define Package/iptables-snmp
   URL:=http://www.nobiscuit.com/iptables-snmp/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default)
-endef
-
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+  $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
-               all install
+               all install \
+  )
 endef
  
 define Package/iptables-snmp/install