Add maintainer to openldap Makefile
[openwrt/svn-archive/archive.git] / net / iptables-snmp / Makefile
index 519b365baa1cc9c1e50eed510871649e7b1a18cc..f6abb571e206e9cf08d040cb92187f54a72b4c71 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,32 +14,32 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nobiscuit.com/iptables-snmp
 PKG_MD5SUM:=8370d2f0c899461a053da491400119d1
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/iptables-snmp
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+snmpd
+  DEPENDS:=+snmpd +libiptc
   TITLE:=An snmpd plugin to access iptables rules
-  DESCRIPTION:=\
-       This is a plugin that makes iptables rules accessable from snmpd.
   URL:=http://www.nobiscuit.com/iptables-snmp/
+  SUBMENU:=firewall
+endef
+
+define Package/iptables-snmp/description
+       This is a plugin that makes iptables rules accessable from snmpd.
 endef
 
 define Build/Compile   
        $(call Build/Compile/Default, \
                INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
                all install \
        )
 endef
  
 define Package/iptables-snmp/install   
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/iptables-snmp.so $(1)/usr/lib
 endef