UCIfied Polipo (patch by "SnapShot_")
[openwrt/svn-archive/archive.git] / net / iptraf / Makefile
index 2cce96f5dccb7bc8188a7a2382a2fed5e17c7082..33a0acfa19c8d16bcf7665a032213f2289fb3603 100644 (file)
@@ -16,7 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
 PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -27,14 +26,23 @@ define Package/iptraf
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A console-based network monitoring program
-  DESCRIPTION:=\
-       IPTraf is a console-based network statistics utility for Linux. It gathers \\\
-       a variety of figures such as TCP connection packet and byte counts, \\\
-       interface statistics and activity indicators, TCP/UDP traffic breakdowns, \\\
-       and LAN station packet and byte counts.
   URL:=http://iptraf.seul.org/
 endef
 
+define Package/iptraf/description
+       IPTraf is a console-based network statistics utility for Linux. It gathers 
+       a variety of figures such as TCP connection packet and byte counts, 
+       interface statistics and activity indicators, TCP/UDP traffic breakdowns, 
+       and LAN station packet and byte counts.
+endef
+
+define Package/iptraf/postinst
+#!/bin/sh
+if [ -z "$${IPKG_INSTROOT}" ]; then
+       mkdir -p $${IPKG_INSTROOT}/var/log/iptraf $${IPKG_INSTROOT}/var/run/iptraf $${IPKG_INSTROOT}/var/lib/iptraf/
+fi
+endef
+
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
@@ -51,9 +59,6 @@ endef
 define Package/iptraf/install  
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/var/lib/iptraf/
-       echo "$(PKG_VERSION)" > $(1)/var/lib/iptraf/version
-       $(INSTALL_DIR) $(1)/var/log/iptraf $(1)/var/run/iptraf
 endef
 
 $(eval $(call BuildPackage,iptraf))