[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / iptraf / Makefile
index 02c31ee18c287a8484aa74084af351a91c175bbc..874f309713d92377f947024dc0dd57ceb4c1ea86 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,15 +11,13 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=iptraf
 PKG_VERSION:=3.0.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,13 +26,15 @@ define Package/iptraf
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A console-based network monitoring program
-  DESCRIPTION:=IPTraf is a console-based network statistics utility for Linux. It gathers\\\
-a variety of figures such as TCP connection packet and byte counts,\\\
-interface statistics and activity indicators, TCP/UDP traffic breakdowns,\\\
-and LAN station packet and byte counts.\\\
   URL:=http://iptraf.seul.org/
 endef
 
+define Package/iptraf/description
+       IPTraf is a console-based network statistics utility for Linux. It gathers 
+       a variety of figures such as TCP connection packet and byte counts, 
+       interface statistics and activity indicators, TCP/UDP traffic breakdowns, 
+       and LAN station packet and byte counts.
+endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
@@ -49,10 +50,11 @@ define Build/Compile
 endef
 
 define Package/iptraf/install  
-       install -d -m0755 $(1)/usr/bin \
-                         $(1)/var/run/iptraf \
-                         $(1)/var/lib/iptraf
-       install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/var/lib/iptraf/
+       echo "$(PKG_VERSION)" > $(1)/var/lib/iptraf/version
+       $(INSTALL_DIR) $(1)/var/log/iptraf $(1)/var/run/iptraf
 endef
 
 $(eval $(call BuildPackage,iptraf))