[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / iptraf / Makefile
index 78124375f460ca734d2ea4b5cea2f1d16558510a..874f309713d92377f947024dc0dd57ceb4c1ea86 100644 (file)
@@ -16,7 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
 PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -27,14 +26,16 @@ define Package/iptraf
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A console-based network monitoring program
-  DESCRIPTION:=\
-       IPTraf is a console-based network statistics utility for Linux. It gathers \\\
-       a variety of figures such as TCP connection packet and byte counts, \\\
-       interface statistics and activity indicators, TCP/UDP traffic breakdowns, \\\
-       and LAN station packet and byte counts.
   URL:=http://iptraf.seul.org/
 endef
 
+define Package/iptraf/description
+       IPTraf is a console-based network statistics utility for Linux. It gathers 
+       a variety of figures such as TCP connection packet and byte counts, 
+       interface statistics and activity indicators, TCP/UDP traffic breakdowns, 
+       and LAN station packet and byte counts.
+endef
+
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
@@ -49,8 +50,11 @@ define Build/Compile
 endef
 
 define Package/iptraf/install  
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/var/lib/iptraf/
+       echo "$(PKG_VERSION)" > $(1)/var/lib/iptraf/version
+       $(INSTALL_DIR) $(1)/var/log/iptraf $(1)/var/run/iptraf
 endef
 
 $(eval $(call BuildPackage,iptraf))