[packages] transmission: update to 2.20 final
[openwrt/svn-archive/archive.git] / net / iptraf / Makefile
index 2cce96f5dccb7bc8188a7a2382a2fed5e17c7082..99439ef5fbb00d35c2317b54a09add2d2c3e15ad 100644 (file)
@@ -1,24 +1,20 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iptraf
-PKG_VERSION:=3.0.0
-PKG_RELEASE:=1
+PKG_VERSION:=3.0.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
-PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=004c2c005a1b78739e22bc49d33e244d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,33 +23,41 @@ define Package/iptraf
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=A console-based network monitoring program
-  DESCRIPTION:=\
-       IPTraf is a console-based network statistics utility for Linux. It gathers \\\
-       a variety of figures such as TCP connection packet and byte counts, \\\
-       interface statistics and activity indicators, TCP/UDP traffic breakdowns, \\\
-       and LAN station packet and byte counts.
   URL:=http://iptraf.seul.org/
 endef
 
-define Build/Compile   
+define Package/iptraf/description
+  IPTraf is a console-based network statistics utility for Linux. It gathers a
+  variety of figures such as TCP connection packet and byte counts, interface
+  statistics and activity indicators, TCP/UDP traffic breakdowns, and LAN
+  station packet and byte counts.
+endef
+
+define Package/iptraf/postinst
+#!/bin/sh
+if [ -z "$${IPKG_INSTROOT}" ]; then
+       mkdir -p $${IPKG_INSTROOT}/var/log/iptraf \
+                $${IPKG_INSTROOT}/var/run/iptraf \
+                $${IPKG_INSTROOT}/var/lib/iptraf
+fi
+endef
+
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                DEBUG="" \
-               INCLUDEDIR="-I../support -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDOPTS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               INCLUDEDIR="-I../support $(TARGET_CPPFLAGS)" \
+               LDOPTS="$(TARGET_LDFLAGS)" \
                PLATFORM="-DPLATFORM=\\\"Linux/$(ARCH)\\\"" \
                TARGET="/usr/bin" \
                WORKDIR="/var/lib/iptraf" \
                all
 endef
 
-define Package/iptraf/install  
+define Package/iptraf/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/var/lib/iptraf/
-       echo "$(PKG_VERSION)" > $(1)/var/lib/iptraf/version
-       $(INSTALL_DIR) $(1)/var/log/iptraf $(1)/var/run/iptraf
 endef
 
 $(eval $(call BuildPackage,iptraf))