[packages] iptraf: add patch to make iptraf recognize athX interfaces - thanks Jose...
[openwrt/svn-archive/archive.git] / net / iptraf / Makefile
index a20959c8e1785eb31761f8bf250a39a719f25d6d..99439ef5fbb00d35c2317b54a09add2d2c3e15ad 100644 (file)
@@ -8,15 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iptraf
-PKG_VERSION:=3.0.0
-PKG_RELEASE:=1
+PKG_VERSION:=3.0.1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://iptraf.seul.org/pub/iptraf/ \
        ftp://the.wiretapped.net/pub/security/network-monitoring/iptraf/
-PKG_MD5SUM:=377371c28ee3c21a76f7024920649ea8
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=004c2c005a1b78739e22bc49d33e244d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,20 +27,22 @@ define Package/iptraf
 endef
 
 define Package/iptraf/description
-       IPTraf is a console-based network statistics utility for Linux. It gathers 
-       a variety of figures such as TCP connection packet and byte counts, 
-       interface statistics and activity indicators, TCP/UDP traffic breakdowns, 
-       and LAN station packet and byte counts.
+  IPTraf is a console-based network statistics utility for Linux. It gathers a
+  variety of figures such as TCP connection packet and byte counts, interface
+  statistics and activity indicators, TCP/UDP traffic breakdowns, and LAN
+  station packet and byte counts.
 endef
 
 define Package/iptraf/postinst
 #!/bin/sh
 if [ -z "$${IPKG_INSTROOT}" ]; then
-       mkdir -p $${IPKG_INSTROOT}/var/log/iptraf $${IPKG_INSTROOT}/var/run/iptraf $${IPKG_INSTROOT}/var/lib/iptraf/
+       mkdir -p $${IPKG_INSTROOT}/var/log/iptraf \
+                $${IPKG_INSTROOT}/var/run/iptraf \
+                $${IPKG_INSTROOT}/var/lib/iptraf
 fi
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)/src \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
@@ -55,7 +55,7 @@ define Build/Compile
                all
 endef
 
-define Package/iptraf/install  
+define Package/iptraf/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/iptraf $(1)/usr/bin/
 endef