[packages] keepalived: update to v1.1.19
[openwrt/svn-archive/archive.git] / net / keepalived / Makefile
index 8a93be54b6bfbb8d6a61fc94208087374f01dbc0..6fc179024754d8f7602b1e026f96e869a17d65e2 100644 (file)
@@ -1,20 +1,19 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
-PKG_VERSION:=1.1.15
+PKG_VERSION:=1.1.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://www.keepalived.org/software
-PKG_MD5SUM:=4c93f5d8b6bfabe84b02828a5bbb7aa0
+PKG_MD5SUM:=a35b8d9d462810f7650d292bd7457523
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -33,7 +32,7 @@ define Package/keepalived/description
 endef
 
 define Package/keepalived/conffiles
- /etc/keepalived/keepalived.conf
+/etc/keepalived/keepalived.conf
 endef
 
 acvar=$(subst -,_,$(subst .,_,$(subst /,_,$(1))))
@@ -45,10 +44,10 @@ CONFIGURE_ARGS+= \
        --disable-strip \
        --disable-lvs \
        --disable-lvs-syncd \
-       --with-kernel-dir="$(LINUX_DIR)" \
+       --with-kernel-dir="$(LINUX_DIR)"
 
 CONFIGURE_VARS+= \
-       ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=no \
+       ac_cv_file_$(call acvar,$(LINUX_DIR)/net/core/link_watch.c)=yes
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
@@ -61,11 +60,11 @@ endef
 
 define Package/keepalived/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/keepalived
-       $(CP) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/keepalived.conf
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
 endef