replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / knock / Makefile
index e3d6b8e1028893d739ae2f6c84df00457dba0abe..0f9a04477682fd906db605f308df6650874cd12d 100644 (file)
@@ -75,14 +75,14 @@ define Build/Compile
 endef
        
 define Package/knock/install   
-       install -d -m0755 $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/knock $(1)/usr/bin/
 endef
 
 define Package/kockd/install
-       install -d -m0755 $(1)/etc
+       $(INSTALL_DIR) $(1)/etc
        install -m0600 $(PKG_INSTALL_DIR)/etc/knockd.conf $(1)/etc/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/knockd $(1)/usr/sbin/
 endef