fix zabbix build with the SDK
[openwrt/svn-archive/archive.git] / net / l2tpns / Makefile
index 323a6dce1053efcb697c204157d2259201669288..13d508fd5d0e6f7f5dc9acafd40c8c86c6ffc776 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=l2tpns
 PKG_VERSION:=2.1.14
 PKG_RELEASE:=1
-PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
 
-PKG_SOURCE_URL:=@SF/l2tpns
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/l2tpns
+PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,10 +27,11 @@ define Package/l2tpns
   CATEGORY:=Network
   DEPENDS:=+libcli
   TITLE:=An L2TP enhanced server
-  DESCRIPTION:=l2tpns is a layer 2 tunneling protocol network server (LNS).\\\
-       it supports up to 65535 concurrent sessions per server/cluster\\\
-       plus ISP features such as rate limiting, walled garden, usage\\\
-       accounting, and more.\\\
+  DESCRIPTION:=\
+       l2tpns is a layer 2 tunneling protocol network server (LNS).\\\
+       it supports up to 65535 concurrent sessions per server/cluster \\\
+       plus ISP features such as rate limiting, walled garden, usage \\\
+       accounting, and more.
   URL:=http://sourceforge.net/projects/l2tpns
 endef
 
@@ -40,15 +42,21 @@ define Package/l2tpns/conffiles
 endef
        
 define Build/Compile
-  $(call Build/Compile/Default, LD="$(TARGET_CC)" OPTIM="$(TARGET_CFLAGS)" STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) all install)
+       $(call Build/Compile/Default, \
+               LD="$(TARGET_CC)" \
+               OPTIM="$(TARGET_CFLAGS)" \
+               STAGING_DIR="$(STAGING_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
 endef
 
 define Package/l2tpns/install  
-       install -d -m0755 $(1)/etc/l2tpns
+       $(INSTALL_DIR) $(1)/etc/l2tpns
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tpns/* $(1)/etc/l2tpns/
-       install -d -m0755 $(1)/usr/lib/l2tpns
+       $(INSTALL_DIR) $(1)/usr/lib/l2tpns
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tpns/* $(1)/usr/lib/l2tpns/
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef