[package] move cd option to proper place, patch from Stefan Bethke.
[openwrt/svn-archive/archive.git] / net / l2tpns / Makefile
index e363df8ae5b9dbedb5e698756a120187eaddc341..c64378de134f942faae1fc690380f80600370d8c 100644 (file)
@@ -1,23 +1,19 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=l2tpns
-PKG_VERSION:=2.1.14
+PKG_VERSION:=2.1.21
 PKG_RELEASE:=1
-PKG_MD5SUM:=2a0ee2a3678160c335f1d68c17c4f871
 
-PKG_SOURCE_URL:=@SF/l2tpns
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@SF/l2tpns
+PKG_MD5SUM:=385c58055723ebc6c38062acd2db9c2c
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,11 +22,15 @@ define Package/l2tpns
   CATEGORY:=Network
   DEPENDS:=+libcli
   TITLE:=An L2TP enhanced server
-  DESCRIPTION:=l2tpns is a layer 2 tunneling protocol network server (LNS).\\\
-       it supports up to 65535 concurrent sessions per server/cluster\\\
-       plus ISP features such as rate limiting, walled garden, usage\\\
-       accounting, and more.\\\
   URL:=http://sourceforge.net/projects/l2tpns
+  SUBMENU:=VPN
+endef
+
+define Package/l2tpns/description
+       l2tpns is a layer 2 tunneling protocol network server (LNS).
+       it supports up to 65535 concurrent sessions per server/cluster
+       plus ISP features such as rate limiting, walled garden, usage
+       accounting, and more.
 endef
 
 define Package/l2tpns/conffiles
@@ -40,22 +40,22 @@ define Package/l2tpns/conffiles
 endef
        
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)" \
+       $(call Build/Compile/Default, \
                LD="$(TARGET_CC)" \
                OPTIM="$(TARGET_CFLAGS)" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               STAGING_DIR=$(STAGING_DIR) \
-               all install
+               STAGING_DIR="$(STAGING_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
 endef
 
 define Package/l2tpns/install  
-       install -d -m0755 $(1)/etc/l2tpns
+       $(INSTALL_DIR) $(1)/etc/l2tpns
        $(CP) $(PKG_INSTALL_DIR)/etc/l2tpns/* $(1)/etc/l2tpns/
-       install -d -m0755 $(1)/usr/lib/l2tpns
+       $(INSTALL_DIR) $(1)/usr/lib/l2tpns
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/l2tpns/* $(1)/usr/lib/l2tpns/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,l2tpns))