Update lft to 3.1 (#3631)
[openwrt/svn-archive/archive.git] / net / lft / Makefile
index a1fc10dbe61bfde6efebcc8efe8ec70491161b3b..d2358e19d63586d854fb9dfdc7c7073534f71e01 100644 (file)
@@ -9,14 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lft
-PKG_VERSION:=2.5
+PKG_VERSION:=3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://ftp.fredan.se/pub/gentoo.org/distfiles
-PKG_MD5SUM:=5b0f45addbb371cc076fe6d9d9694546
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://pwhois.org/get
+PKG_MD5SUM:=70e69706e7600f34c0dfb54e2ee5eb01
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,6 +26,15 @@ define Package/lft
   URL:=http://pwhois.org/lft
 endef
 
+define Package/lft/description
+       LFT, short for Layer Four Traceroute, is a sort of 'traceroute' that
+       often works much faster (than the commonly-used Van Jacobson method)
+       and goes through many configurations of packet-filters (firewalls).
+       More importantly, LFT implements numerous other features including AS
+       number lookups through several reliable sources, loose source routing,
+       netblock name lookups, et al.
+endef
+
 define Build/Configure 
        $(call Build/Configure/Default, \
                --with-pcap="$(STAGING_DIR)/usr" \