[package] add directory option to spawn-fcgi (#4355), thanks Raphael
[openwrt/svn-archive/archive.git] / net / lighttpd / Makefile
index 1c74d78fbde833d09cc615459ac2782a1f88c056..555a50cca25cb849967f37e7560d2725d6cf008f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.11
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.20
+PKG_RELEASE:=3
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
-PKG_MD5SUM:=f55eebb9815c94a7de35906bb557ecd3
-PKG_CAT:=zcat
+PKG_MD5SUM:=ed6ee0bb714f393219a32768d86984d8
 
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/lighttpd
-  MENU:=1
+define Package/lighttpd/Default
+  SUBMENU:=Web
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libopenssl +libpcre +libpthread
-  TITLE:=A flexible and lightweight web server
   URL:=http://www.lighttpd.net/
 endef
 
-define Package/lighttpd/conffiles
-/etc/lighttpd.conf
-/etc/default/lighttpd
-/etc/init.d/lighttpd
+define Package/lighttpd
+  $(call Package/lighttpd/Default)
+  MENU:=1
+  DEPENDS:=+libopenssl +libpcre +libpthread +libsqlite3 +libxml2
+  TITLE:=A flexible and lightweight web server
 endef
 
 define Package/lighttpd-mod-accesslog
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Access logging module
 endef
 
 define Package/lighttpd-mod-alias
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Directory alias module
 endef
 
 define Package/lighttpd-mod-auth
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Authentication module
 endef
 
 define Package/lighttpd-mod-cgi
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=CGI module
 endef
 
 define Package/lighttpd-mod-evasive
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Evasive module
 endef
 
 define Package/lighttpd-mod-expire
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Expire module
 endef
 
 define Package/lighttpd-mod-fastcgi
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=FastCGI module
 endef
 
 define Package/lighttpd-mod-proxy
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Proxy module
 endef
 
 define Package/lighttpd-mod-redirect
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=URL redirection module
 endef
 
 define Package/lighttpd-mod-rewrite
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=URL rewriting module
 endef
 
 define Package/lighttpd-mod-setenv
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Environment variable setting module
 endef
 
 define Package/lighttpd-mod-simple-vhost
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Simple virtual hosting module
 endef
 
 define Package/lighttpd-mod-ssi
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=SSI module
 endef
 
 define Package/lighttpd-mod-status
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=Server status display module
 endef
 
 define Package/lighttpd-mod-usertrack
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=User tracking module
 endef
 
 define Package/lighttpd-mod-webdav
-  $(call Package/lighttpd)
+  $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=WebDAV module
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               PCRE_LIB="-lpcre" \
-               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib/lighttpd \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc/lighttpd \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --without-attr \
-                       --without-bzip2 \
-                       --without-fam \
-                       --without-gdbm \
-                       --without-ldap \
-                       --without-lua \
-                       --without-memcache \
-                       --without-mysql \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --with-pcre \
-                       --without-valgrind \
-                       --with-webdav-props \
-       );
-endef
+
+CONFIGURE_ARGS+= \
+       --libdir=/usr/lib/lighttpd \
+       --sysconfdir=/etc/lighttpd \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-attr \
+       --without-bzip2 \
+       --without-fam \
+       --without-gdbm \
+       --without-ldap \
+       --without-lua \
+       --without-memcache \
+       --without-mysql \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-pcre \
+       --without-valgrind \
+       --with-webdav-props \
+
+CONFIGURE_VARS+= \
+       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
+       PCRE_LIB="-lpcre" \
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
+endef
+
+define Package/lighttpd/conffiles
+/etc/lighttpd.conf
+/etc/default/lighttpd
 endef
 
 define Package/lighttpd/install
-       install -m0755 -d $(1)/etc
-       install -m0644 ./files/lighttpd.conf $(1)/etc/
-       install -m0755 -d $(1)/etc/default
-       install -m0644 ./files/lighttpd.default $(1)/etc/default/lighttpd
-       install -m0755 -d $(1)/etc/init.d
-       install -m0755 ./files/lighttpd.init $(1)/etc/init.d/lighttpd
-       install -m0755 -d $(1)/usr/lib/lighttpd
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DATA) ./files/lighttpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(INSTALL_DATA) ./files/lighttpd.default $(1)/etc/default/lighttpd
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/lighttpd.init $(1)/etc/init.d/lighttpd
+       $(INSTALL_DIR) $(1)/usr/lib/lighttpd
        for m in dirlisting indexfile staticfile; do \
                $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$$${m}.so $(1)/usr/lib/lighttpd/ ; \
        done
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lighttpd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lighttpd $(1)/usr/sbin/
 endef
 
 define BuildPlugin
   define Package/$(1)/install
-       [ -z "$(2)" ] || install -d -m0755 $$(1)/usr/lib/lighttpd
+       [ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/lighttpd
        for m in $(2); do \
                $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$$$$$$${m}.so $$(1)/usr/lib/lighttpd/ ; \
        done