packages: lighttpd: update to 1.4.32
[openwrt/svn-archive/archive.git] / net / lighttpd / Makefile
index 2ee5e34270053ad5146d2584b8901cc854f69b53..8548dd2bf536d4d14ac39277f2839d37599e8f6b 100644 (file)
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
+       #
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,20 +8,23 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.26
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.32
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x
+PKG_MD5SUM:=e5a6f57fc371a10646ff1a57056fa9c0
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
-PKG_MD5SUM:=a682c8efce47a2f4263a247ba0813c9b
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP:=libtool
+PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lighttpd/Default
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.lighttpd.net/
@@ -30,176 +33,19 @@ endef
 define Package/lighttpd
   $(call Package/lighttpd/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpcre +libpthread
+  DEPENDS:=+LIGHTTPD_SSL:libopenssl +libpcre +libpthread
   TITLE:=A flexible and lightweight web server
 endef
 
-define Package/lighttpd-mod-access
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Access restrictions module
-endef
-
-define Package/lighttpd-mod-accesslog
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Access logging module
-endef
-
-define Package/lighttpd-mod-alias
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Directory alias module
-endef
-
-define Package/lighttpd-mod-auth
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Authentication module
-endef
-
-define Package/lighttpd-mod-cgi
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=CGI module
-endef
-
-define Package/lighttpd-mod-cml
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Cache Meta Language module
-endef
-
-define Package/lighttpd-mod-compress
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +zlib
-  TITLE:=Compress output module
-endef
-
-define Package/lighttpd-mod-evasive
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Evasive module
-endef
-
-define Package/lighttpd-mod-expire
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Expire module
-endef
-
-define Package/lighttpd-mod-extforward
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Extract client IP module
-endef
-
-define Package/lighttpd-mod-fastcgi
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=FastCGI module
-endef
-
-define Package/lighttpd-mod-flv-streaming
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=flv streaming module
-endef
-
-define Package/lighttpd-mod-magnet
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=magnet module
-endef
-
-define Package/lighttpd-mod-mysql-vhost
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libmysqlclient
-  TITLE:=Mysql virtual hosting module
-endef
-
-define Package/lighttpd-mod-proxy
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Proxy module
-endef
-
-define Package/lighttpd-mod-redirect
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libpcre
-  TITLE:=URL redirection module
-endef
-
-define Package/lighttpd-mod-rewrite
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libpcre
-  TITLE:=URL rewriting module
-endef
-
-define Package/lighttpd-mod-rrdtool
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=rrdtool module
-endef
-
-define Package/lighttpd-mod-scgi
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=SCGI module
-endef
-
-define Package/lighttpd-mod-secdownload
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Secure and fast download module
-endef
-
-define Package/lighttpd-mod-setenv
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Environment variable setting module
-endef
-
-define Package/lighttpd-mod-simple-vhost
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Simple virtual hosting module
-endef
-
-define Package/lighttpd-mod-ssi
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libpcre
-  TITLE:=SSI module
-endef
-
-define Package/lighttpd-mod-status
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=Server status display module
-endef
-
-define Package/lighttpd-mod-trigger-b4-dl
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libpcre
-  TITLE:=Trigger before download module
-endef
-
-define Package/lighttpd-mod-userdir
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=User directory module
-endef
-
-define Package/lighttpd-mod-usertrack
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
-  TITLE:=User tracking module
-endef
-
-define Package/lighttpd-mod-webdav
-  $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd +libsqlite3 +libuuid +libxml2
-  TITLE:=WebDAV module
+define Package/lighttpd/config
+config LIGHTTPD_SSL
+       bool "SSL support"
+       depends on PACKAGE_lighttpd
+       default y
+       help
+         Implements SSL support in lighttpd (using libopenssl). This
+         option is required if you enable the SSL engine in your
+         lighttpd confguration file.
 endef
 
 CONFIGURE_ARGS+= \
@@ -215,22 +61,27 @@ CONFIGURE_ARGS+= \
        --without-ldap \
        --without-lua \
        --without-memcache \
-       --without-mysql \
-       --with-openssl="$(STAGING_DIR)/usr" \
        --with-pcre \
        --without-valgrind \
+        $(call autoconf_bool,CONFIG_IPV6,ipv6)
 
 CONFIGURE_VARS+= \
        PCRE_LIB="-lpcre" \
 
-ifneq ($(CONFIG_LARGEFILE),y)
+ifneq ($(strip $(CONFIG_LIGHTTPD_SSL)),)
   CONFIGURE_ARGS+= \
-       --disable-lfs
+       --with-openssl="$(STAGING_DIR)/usr"
+else
+  CONFIGURE_ARGS+= \
+       --without-openssl
 endif
 
-ifeq ($(CONFIG_IPV6),y)
+ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-mysql-vhost),)
   CONFIGURE_ARGS+= \
-       --enable-ipv6
+       --with-mysql
+else
+  CONFIGURE_ARGS+= \
+       --without-mysql
 endif
 
 ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-webdav),)
@@ -255,14 +106,13 @@ endef
 
 define Package/lighttpd/conffiles
 /etc/lighttpd/lighttpd.conf
-/etc/default/lighttpd
 endef
 
 define Package/lighttpd/install
        $(INSTALL_DIR) $(1)/etc/lighttpd
        $(INSTALL_DATA) ./files/lighttpd.conf $(1)/etc/lighttpd/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(INSTALL_DATA) ./files/lighttpd.default $(1)/etc/default/lighttpd
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/doc/config/conf.d/mime.conf $(1)/etc/lighttpd/
+       $(INSTALL_DIR) $(1)/etc/lighttpd/conf.d
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/lighttpd.init $(1)/etc/init.d/lighttpd
        $(INSTALL_DIR) $(1)/usr/lib/lighttpd
@@ -274,40 +124,57 @@ define Package/lighttpd/install
 endef
 
 define BuildPlugin
-  define Package/$(1)/install
-       [ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/lighttpd
-       for m in $(2); do \
-               $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$$$$$$$${m}.so $$(1)/usr/lib/lighttpd/ ; \
-       done
+  define Package/lighttpd-mod-$(1)
+    $(call Package/lighttpd/Default)
+    DEPENDS:=lighttpd
+    ifneq ($(3),)
+      DEPENDS+= $(3)
+    endif
+    TITLE:=$(2) module
   endef
 
-  $$(eval $$(call BuildPackage,$(1)))
+  define Package/lighttpd-mod-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/lighttpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lighttpd/mod_$(1).so $$(1)/usr/lib/lighttpd
+       $(INSTALL_DIR) $$(1)/etc/lighttpd/conf.d
+       if [ -f $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf ]; then \
+               $(CP) $(PKG_BUILD_DIR)/doc/config/conf.d/$(1).conf $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
+       else \
+               echo 'server.modules += ( "mod_$(1)" )' > $$(1)/etc/lighttpd/conf.d/$(4)-$(1).conf ; \
+       fi
+  endef
+
+  $$(eval $$(call BuildPackage,lighttpd-mod-$(1)))
 endef
 
 $(eval $(call BuildPackage,lighttpd))
-$(eval $(call BuildPlugin,lighttpd-mod-access,access))
-$(eval $(call BuildPlugin,lighttpd-mod-accesslog,accesslog))
-$(eval $(call BuildPlugin,lighttpd-mod-alias,alias))
-$(eval $(call BuildPlugin,lighttpd-mod-auth,auth))
-$(eval $(call BuildPlugin,lighttpd-mod-cgi,cgi))
-$(eval $(call BuildPlugin,lighttpd-mod-cml,cml))
-$(eval $(call BuildPlugin,lighttpd-mod-compress,compress))
-$(eval $(call BuildPlugin,lighttpd-mod-evasive,evasive))
-$(eval $(call BuildPlugin,lighttpd-mod-expire, expire))
-$(eval $(call BuildPlugin,lighttpd-mod-extforward, extforward))
-$(eval $(call BuildPlugin,lighttpd-mod-fastcgi,fastcgi))
-$(eval $(call BuildPlugin,lighttpd-mod-flv-streaming,flv_streaming))
-$(eval $(call BuildPlugin,lighttpd-mod-proxy,proxy))
-$(eval $(call BuildPlugin,lighttpd-mod-redirect,redirect))
-$(eval $(call BuildPlugin,lighttpd-mod-rewrite,rewrite))
-$(eval $(call BuildPlugin,lighttpd-mod-rrdtool,rrdtool))
-$(eval $(call BuildPlugin,lighttpd-mod-scgi,scgi))
-$(eval $(call BuildPlugin,lighttpd-mod-secdownload,secdownload))
-$(eval $(call BuildPlugin,lighttpd-mod-setenv,setenv))
-$(eval $(call BuildPlugin,lighttpd-mod-simple-vhost,simple_vhost))
-$(eval $(call BuildPlugin,lighttpd-mod-ssi,ssi))
-$(eval $(call BuildPlugin,lighttpd-mod-status,status))
-$(eval $(call BuildPlugin,lighttpd-mod-trigger-b4-dl,trigger_b4_dl))
-$(eval $(call BuildPlugin,lighttpd-mod-userdir,userdir))
-$(eval $(call BuildPlugin,lighttpd-mod-usertrack,usertrack))
-$(eval $(call BuildPlugin,lighttpd-mod-webdav,webdav))
+$(eval $(call BuildPlugin,access,Access restrictions,,10))
+$(eval $(call BuildPlugin,accesslog,Access logging,,10))
+$(eval $(call BuildPlugin,alias,Directory alias,,10))
+$(eval $(call BuildPlugin,auth,Authentication,,05))
+$(eval $(call BuildPlugin,cgi,CGI,,10))
+$(eval $(call BuildPlugin,cml,Cache Meta Language,,10))
+$(eval $(call BuildPlugin,compress,Compress output,+zlib,10))
+$(eval $(call BuildPlugin,evasive,Evasive,,10))
+$(eval $(call BuildPlugin,evhost,Exnhanced Virtual-Hosting,,10))
+$(eval $(call BuildPlugin,expire,Expire,,10))
+$(eval $(call BuildPlugin,extforward,Extract client,,10))
+$(eval $(call BuildPlugin,fastcgi,FastCGI,,10))
+$(eval $(call BuildPlugin,flv_streaming,FLV streaming,,10))
+$(eval $(call BuildPlugin,magnet,Magnet,,10))
+$(eval $(call BuildPlugin,mysql_vhost,Mysql virtual hosting,+libmysqlclient,10))
+$(eval $(call BuildPlugin,proxy,Proxy,,10))
+$(eval $(call BuildPlugin,redirect,URL redirection,+libpcre,10))
+$(eval $(call BuildPlugin,rewrite,URL rewriting,+libpcre,10))
+$(eval $(call BuildPlugin,rrdtool,RRDtool,,10))
+$(eval $(call BuildPlugin,scgi,SCGI,,10))
+$(eval $(call BuildPlugin,secdownload,Secure and fast download,,10))
+$(eval $(call BuildPlugin,setenv,Environment variable setting,,10))
+$(eval $(call BuildPlugin,simple_vhost,Simple virtual hosting,,10))
+$(eval $(call BuildPlugin,ssi,SSI,+libpcre,10))
+$(eval $(call BuildPlugin,status,Server status display,,10))
+$(eval $(call BuildPlugin,trigger_b4_dl,Trigger before download,+libpcre,10))
+$(eval $(call BuildPlugin,userdir,User directory,,10))
+$(eval $(call BuildPlugin,usertrack,User tracking,,10))
+$(eval $(call BuildPlugin,webdav,WebDAV,+libsqlite3 +libuuid +libxml2,10))
+