[package] update lighttpd to 1.4.25 (#6240)
[openwrt/svn-archive/archive.git] / net / lighttpd / Makefile
index b8ef02baf3a6ebc0493dcb5f64433af1ff30a5eb..9925c781de05540cb4789f30be3e7bab20e3f012 100644 (file)
@@ -1,22 +1,21 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.19
-PKG_RELEASE:=2
+PKG_VERSION:=1.4.25
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.lighttpd.net/download/
-PKG_MD5SUM:=d787374e4e4aaa09d5cfa9ab9d23ad40
+PKG_SOURCE_URL:=http://download.lighttpd.net/lighttpd/releases-1.4.x/
+PKG_MD5SUM:=2027c49fb46530e45338c5e2da13c02f
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,10 +29,16 @@ endef
 define Package/lighttpd
   $(call Package/lighttpd/Default)
   MENU:=1
-  DEPENDS:=+libopenssl +libpcre +libpthread +libsqlite3 +libxml2
+  DEPENDS:=+libopenssl +libpcre +libpthread
   TITLE:=A flexible and lightweight web server
 endef
 
+define Package/lighttpd-mod-access
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=Access restrictions module
+endef
+
 define Package/lighttpd-mod-accesslog
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
@@ -58,6 +63,18 @@ define Package/lighttpd-mod-cgi
   TITLE:=CGI module
 endef
 
+define Package/lighttpd-mod-cml
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=Cache Meta Language module
+endef
+
+define Package/lighttpd-mod-compress
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd +zlib
+  TITLE:=Compress output module
+endef
+
 define Package/lighttpd-mod-evasive
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
@@ -70,12 +87,36 @@ define Package/lighttpd-mod-expire
   TITLE:=Expire module
 endef
 
+define Package/lighttpd-mod-extforward
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=Extract client IP module
+endef
+
 define Package/lighttpd-mod-fastcgi
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
   TITLE:=FastCGI module
 endef
 
+define Package/lighttpd-mod-flv-streaming
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=flv streaming module
+endef
+
+define Package/lighttpd-mod-magnet
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=magnet module
+endef
+
+define Package/lighttpd-mod-mysql-vhost
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd +libmysqlclient
+  TITLE:=Mysql virtual hosting module
+endef
+
 define Package/lighttpd-mod-proxy
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
@@ -84,16 +125,34 @@ endef
 
 define Package/lighttpd-mod-redirect
   $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
+  DEPENDS:=lighttpd +libpcre
   TITLE:=URL redirection module
 endef
 
 define Package/lighttpd-mod-rewrite
   $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
+  DEPENDS:=lighttpd +libpcre
   TITLE:=URL rewriting module
 endef
 
+define Package/lighttpd-mod-rrdtool
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=rrdtool module
+endef
+
+define Package/lighttpd-mod-scgi
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=SCGI module
+endef
+
+define Package/lighttpd-mod-secdownload
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=Secure and fast download module
+endef
+
 define Package/lighttpd-mod-setenv
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
@@ -108,7 +167,7 @@ endef
 
 define Package/lighttpd-mod-ssi
   $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
+  DEPENDS:=lighttpd +libpcre
   TITLE:=SSI module
 endef
 
@@ -118,6 +177,18 @@ define Package/lighttpd-mod-status
   TITLE:=Server status display module
 endef
 
+define Package/lighttpd-mod-trigger-b4-dl
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd +libpcre
+  TITLE:=Trigger before download module
+endef
+
+define Package/lighttpd-mod-userdir
+  $(call Package/lighttpd/Default)
+  DEPENDS:=lighttpd
+  TITLE:=User directory module
+endef
+
 define Package/lighttpd-mod-usertrack
   $(call Package/lighttpd/Default)
   DEPENDS:=lighttpd
@@ -126,11 +197,10 @@ endef
 
 define Package/lighttpd-mod-webdav
   $(call Package/lighttpd/Default)
-  DEPENDS:=lighttpd
+  DEPENDS:=lighttpd +libsqlite3 +libuuid +libxml2
   TITLE:=WebDAV module
 endef
 
-
 CONFIGURE_ARGS+= \
        --libdir=/usr/lib/lighttpd \
        --sysconfdir=/etc/lighttpd \
@@ -148,24 +218,47 @@ CONFIGURE_ARGS+= \
        --with-openssl="$(STAGING_DIR)/usr" \
        --with-pcre \
        --without-valgrind \
-       --with-webdav-props \
 
 CONFIGURE_VARS+= \
-       CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
        PCRE_LIB="-lpcre" \
 
+ifneq ($(CONFIG_LARGEFILE),y)
+  CONFIGURE_ARGS+= \
+       --disable-lfs
+endif
+
+ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-webdav),)
+  CONFIGURE_ARGS+= \
+       --with-webdav-locks \
+       --with-webdav-props
+  # XXX: needed by sqlite3 to prevent segfaults in mod_webdav.so
+  CONFIGURE_VARS+= \
+       LIBS="-lpthread"
+else
+  CONFIGURE_ARGS+= \
+       --without-webdav-locks \
+       --without-webdav-props
+endif
+
+define Build/Configure
+$(call Build/Configure/Default)
+       # XXX: override pcre (mis)detection by ./configure when cross-compiling
+       echo "#define HAVE_LIBPCRE 1" >>$(PKG_BUILD_DIR)/config.h
+       echo "#define HAVE_PCRE_H 1" >>$(PKG_BUILD_DIR)/config.h
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
 endef
 
 define Package/lighttpd/conffiles
-/etc/lighttpd.conf
+/etc/lighttpd/lighttpd.conf
 /etc/default/lighttpd
 endef
 
 define Package/lighttpd/install
-       $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/lighttpd.conf $(1)/etc/
+       $(INSTALL_DIR) $(1)/etc/lighttpd
+       $(INSTALL_DATA) ./files/lighttpd.conf $(1)/etc/lighttpd/
        $(INSTALL_DIR) $(1)/etc/default
        $(INSTALL_DATA) ./files/lighttpd.default $(1)/etc/default/lighttpd
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -190,19 +283,29 @@ define BuildPlugin
 endef
 
 $(eval $(call BuildPackage,lighttpd))
+$(eval $(call BuildPlugin,lighttpd-mod-access,access))
 $(eval $(call BuildPlugin,lighttpd-mod-accesslog,accesslog))
 $(eval $(call BuildPlugin,lighttpd-mod-alias,alias))
 $(eval $(call BuildPlugin,lighttpd-mod-auth,auth))
 $(eval $(call BuildPlugin,lighttpd-mod-cgi,cgi))
+$(eval $(call BuildPlugin,lighttpd-mod-cml,cml))
+$(eval $(call BuildPlugin,lighttpd-mod-compress,compress))
 $(eval $(call BuildPlugin,lighttpd-mod-evasive,evasive))
 $(eval $(call BuildPlugin,lighttpd-mod-expire, expire))
+$(eval $(call BuildPlugin,lighttpd-mod-extforward, extforward))
 $(eval $(call BuildPlugin,lighttpd-mod-fastcgi,fastcgi))
+$(eval $(call BuildPlugin,lighttpd-mod-flv-streaming,flv_streaming))
 $(eval $(call BuildPlugin,lighttpd-mod-proxy,proxy))
 $(eval $(call BuildPlugin,lighttpd-mod-redirect,redirect))
 $(eval $(call BuildPlugin,lighttpd-mod-rewrite,rewrite))
+$(eval $(call BuildPlugin,lighttpd-mod-rrdtool,rrdtool))
+$(eval $(call BuildPlugin,lighttpd-mod-scgi,scgi))
+$(eval $(call BuildPlugin,lighttpd-mod-secdownload,secdownload))
 $(eval $(call BuildPlugin,lighttpd-mod-setenv,setenv))
 $(eval $(call BuildPlugin,lighttpd-mod-simple-vhost,simple_vhost))
 $(eval $(call BuildPlugin,lighttpd-mod-ssi,ssi))
 $(eval $(call BuildPlugin,lighttpd-mod-status,status))
+$(eval $(call BuildPlugin,lighttpd-mod-trigger-b4-dl,trigger_b4_dl))
+$(eval $(call BuildPlugin,lighttpd-mod-userdir,userdir))
 $(eval $(call BuildPlugin,lighttpd-mod-usertrack,usertrack))
 $(eval $(call BuildPlugin,lighttpd-mod-webdav,webdav))