Revert r23676
[openwrt/svn-archive/archive.git] / net / linuxigd / Makefile
index f198967e33672c2e06d5e59fdeb9e3a94d623bbc..520dc8534f5015ea975e29c3acc6237aa7262409 100644 (file)
@@ -24,22 +24,22 @@ define Package/linuxigd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=UPnP daemon
-  DEPENDS:=+libiptc +libupnp +libpthread
+  DEPENDS:=+libiptc +libupnp +libpthread @!LINUX_2_4
   URL:=http://linux-igd.sourceforge.net/
 endef
 
 define Package/linuxigd/description
-       It implements the UPnP Internet Gateway Device specification (IGD) 
-       and allows UPnP aware clients, such as MSN Messenger, Azureus or 
-       Miranda to work properly from behind a NAT firewall. 
-       
+       It implements the UPnP Internet Gateway Device specification (IGD)
+       and allows UPnP aware clients, such as MSN Messenger, Azureus or
+       Miranda to work properly from behind a NAT firewall.
+
        Please edit /etc/upnpd.conf before using upnpd!
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)  \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DIPTABLES_143" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DIPTABLES_143 -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
                BINDIR="/usr/sbin" \
                MANDIR="/usr/man" \
                HAVE_LIBIPTC=1 \