[packages] linuxigd: fix linking against libiptc family (#6678)
[openwrt/svn-archive/archive.git] / net / linuxigd / Makefile
index d50f1ede63f07a896e4fb6eb5908b6df7c9cb6e4..5bc6624d783b129d24d1721f232d35c13fd0a116 100644 (file)
@@ -5,20 +5,16 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linuxigd
-PKG_VERSION:=0.95
+PKG_VERSION:=1.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-igd
-PKG_MD5SUM:=0f203a2db5e3fb01496b73e417dbd9a6
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=929f5c4878c91d534613b7c7070215d9
 
 PKG_BUILD_DEPENDS:=iptables libupnp
 
@@ -28,20 +24,22 @@ define Package/linuxigd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=UPnP daemon
-  DEPENDS:=+libupnp +libpthread
-  DESCRIPTION:=\
-       It implements the UPnP Internet Gateway Device specification (IGD) \\\
-       and allows UPnP aware clients, such as MSN Messenger, Azureus or \\\
-       Miranda to work properly from behind a NAT firewall. \\\
-       \\\
-       Please edit /etc/upnpd.conf before using upnpd!
+  DEPENDS:=+libiptc +libupnp +libpthread
   URL:=http://linux-igd.sourceforge.net/
 endef
 
+define Package/linuxigd/description
+       It implements the UPnP Internet Gateway Device specification (IGD) 
+       and allows UPnP aware clients, such as MSN Messenger, Azureus or 
+       Miranda to work properly from behind a NAT firewall. 
+       
+       Please edit /etc/upnpd.conf before using upnpd!
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)  \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DIPTABLES_143 -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
                BINDIR="/usr/sbin" \
                MANDIR="/usr/man" \
                HAVE_LIBIPTC=1 \