[package] fix scponly compilation failure (#6986)
[openwrt/svn-archive/archive.git] / net / mac-to-devinfo / Makefile
index 7d4c4e111dd44c5c9520f9c84824f4c7e72c853b..4736fb8ec61b8349700b96eb4a9c630b21509f06 100644 (file)
@@ -1,49 +1,56 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mac-to-devinfo
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mac-to-devinfo
-       SECTION:=net
-       CATEGORY:=Network
-       TITLE:=MAC Address to Device Information
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=MAC Address to Device Information
 endef
 
 define Package/mac-to-devinfo/description
-       Scripts to take a mac address (or ip if the ip is in the arp cache)
-       and translate it into device information (mostly OUI owner, from the
-       IEEE data files, but more information may be available for specific
-       devices/vendors).
+  Scripts to take a mac address (or ip if the ip is in the arp cache)
+  and translate it into device information (mostly OUI owner, from the
+  IEEE data files, but more information may be available for specific
+  devices/vendors).
 endef
 
 define Package/smap-to-devinfo
-       SECTION:=net
-       CATEGORY:=Network
-       DEPENDS:=mac-to-devinfo +smap +httping
-       TITLE:=SIP Device Information from Scan
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=mac-to-devinfo +smap +httping
+  TITLE:=SIP Device Information from Scan
 endef
 
 define Package/smap-to-devinfo/description
-       A script to use smap to discover all SIP devices on the networks
-        (provided ICMP and SIP are allowed to the network from the host) and 
-       translate (through the ip then mac) into the device information.
+  A script to use smap to discover all SIP devices on the networks
+  (provided ICMP and SIP are allowed to the network from the host) and
+  translate (through the ip then mac) into the device information.
 endef
 
 define Package/netdiscover-to-devinfo
-       SECTION:=net
-       CATEGORY:=Network
-       DEPENDS:=mac-to-devinfo +netdiscover
-       TITLE:=Device Information from Scan for MAC addresses
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=mac-to-devinfo +netdiscover
+  TITLE:=Device Information from Scan for MAC addresses
 endef
 
 define Package/netdiscover-to-devinfo/description
-       A script to use netdiscover to discover all devices on the specified
-        arp-able networks and translate into the device information.
+  A script to use netdiscover to discover all devices on the specified
+  arp-able networks and translate into the device information.
 endef
 
 define Build/Prepare
@@ -64,6 +71,7 @@ define Package/mac-to-devinfo/install
        $(INSTALL_BIN) ./files/mac-to-devinfo $(1)/usr/bin
        $(INSTALL_BIN) ./files/ip-to-devinfo $(1)/usr/bin
        $(INSTALL_BIN) ./files/prep-devinfo $(1)/usr/bin
+       $(INSTALL_BIN) ./files/clean-devinfo $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/lib/mac-to-devinfo
        $(INSTALL_BIN) ./files/devinfo-functions.sh $(1)/usr/lib/mac-to-devinfo
        $(INSTALL_DIR) $(1)/usr/share/mac-to-devinfo
@@ -75,6 +83,7 @@ endef
 define Package/smap-to-devinfo/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) ./files/smap-to-devinfo $(1)/usr/bin
+       $(INSTALL_BIN) ./files/netsmap-to-devinfo $(1)/usr/bin
 endef
 
 define Package/netdiscover-to-devinfo/install