massive Makefile cleanup, add missing 'svn:keywords' property
[openwrt/svn-archive/archive.git] / net / maradns / Makefile
index 79ea02c8be1fd473014dbb85d169cf3d995c2865..989bbd90df73e6ecac4e6f528af3dc8984c3db5a 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,10 +11,10 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=maradns
 PKG_VERSION:=1.2.07.2
 PKG_RELEASE:=1
-PKG_MD5SUM:=dc67f6a496e668127871382a40367733
 
-PKG_SOURCE_URL:=http://www.maradns.org/download/1.2/1.2.07.2/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://www.maradns.org/download/1.2/1.2.07.2/
+PKG_MD5SUM:=dc67f6a496e668127871382a40367733
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,7 +27,6 @@ define Package/maradns
   CATEGORY:=Network
   DEPENDS:=+libpthread
   TITLE:=Small and secure DNS Server
-  DESCRIPTION:=A small and secure DNS server
   URL:=http://www.maradns.org/
 endef
 
@@ -35,7 +35,8 @@ define Package/maradns/conffiles
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+       # it's not GNU autoconf stuff
+       (cd $(PKG_BUILD_DIR); \
                $(TARGET_CONFIGURE_OPTS) \
                ./configure \
        );