[packages] freeradius2: update to version 2.1.8
[openwrt/svn-archive/archive.git] / net / matrixtunnel / Makefile
index 656c82477e283fa4a4198e48886e7453b0279587..819f1aaa530ee85be643248f1eebdd1bc5971a5b 100644 (file)
@@ -1,38 +1,42 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=matrixtunnel
-PKG_VERSION:=0.1
-PKG_RELEASE:=1
+PKG_VERSION:=0.2
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://znerol.ch/files
-PKG_MD5SUM:=ffbbe0c50cc1863f6080aca302f7e2c8
-PKG_CAT:=zcat
+PKG_MD5SUM:=af169751efc7d87d500716a48d74ddc5
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+MAKE_PATH:=src
+
 define Package/matrixtunnel
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=VPN
   DEPENDS:=+libmatrixssl
   TITLE:=SSL tunnel based on matrixssl
-  DESCRIPTION:=\
-       matrixtunnel is a stripped down version of stunnel \\\
-       based on matrixssl library.
   URL:=http://znerol.ch/svn/matrixtunnel/trunk/
 endef
 
+define Package/matrixtunnel/description
+       matrixtunnel is a stripped down version of stunnel 
+       based on matrixssl library.
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --without-libiconv-prefix \
@@ -41,15 +45,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/matrixtunnel/install
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/matrixtunnel $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/matrixtunnel $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,matrixtunnel))