[package] fix mercurial dependency against python, thanks KanjiMonster
[openwrt/svn-archive/archive.git] / net / mercurial / Makefile
index 4cad8a83946e1ddae76d53a3cbfff3494a089fe0..3c115fc815d914d46844587e59d1af26b66478ef 100644 (file)
@@ -1,49 +1,41 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mercurial
-PKG_VERSION:=1.1.2
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=http://selenic.com/mercurial/release/
+PKG_SOURCE_URL:=http://mercurial.selenic.com/release
 PKG_SOURCE:=mercurial-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=4fd3b9a2e5dcd025840c3849b136bec8
-PKG_BUILD_DEPENDS:=python
+PKG_MD5SUM:=847359d7488caf8074a69d4b87ca64d2
+PKG_BUILD_DEPENDS:=python-mini
 
 include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python-package.mk)
 
 define Package/mercurial
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=python
+  DEPENDS:=+python
   TITLE:=Mercurial Source Control Management (SCM) system
-  URL:=http://www.selenic.com/mercurial/
+  URL:=http://mercurial.selenic.com/
+  SUBMENU:=Version Control Systems
 endef
 
 define Package/mercurial/description
   A fast, lightweight Source Control Management system designed for efficient handling of very large distributed projects.
 endef
 
-HG_BUILDOPTS= \
-       CC="$(TARGET_CC)" \
-       LDSHARED="$(TARGET_CC) -shared" \
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/python2.5/" \
-       LDFLAGS="-L$(STAGING_DIR)/usr/lib -lpython2.5"
-
 define Build/Compile
-       (cd $(PKG_BUILD_DIR); \
-               $(HG_BUILDOPTS) /usr/bin/python setup.py build; \
-       );
-       (cd $(PKG_BUILD_DIR); \
-               /usr/bin/python setup.py install --prefix="$(PKG_INSTALL_DIR)"; \
-       );
+       $(call Build/Compile/PyMod,, \
+               install --prefix="$(PKG_INSTALL_DIR)", \
+    )
 endef
 
 define Package/mercurial/install