[packages] znc: commit missing parts of r24548
[openwrt/svn-archive/archive.git] / net / mercurial / Makefile
index b1bd42d41152ae3fb54084f9025a8b1ad7933398..3c115fc815d914d46844587e59d1af26b66478ef 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006,2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mercurial
-PKG_VERSION:=1.1.2
-PKG_RELEASE:=1
+PKG_VERSION:=1.6.2
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=http://selenic.com/mercurial/release/
+PKG_SOURCE_URL:=http://mercurial.selenic.com/release
 PKG_SOURCE:=mercurial-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=4fd3b9a2e5dcd025840c3849b136bec8
+PKG_MD5SUM:=847359d7488caf8074a69d4b87ca64d2
 PKG_BUILD_DEPENDS:=python-mini
 
 include $(INCLUDE_DIR)/package.mk
@@ -22,9 +22,9 @@ $(call include_mk, python-package.mk)
 define Package/mercurial
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=python
+  DEPENDS:=+python
   TITLE:=Mercurial Source Control Management (SCM) system
-  URL:=http://www.selenic.com/mercurial/
+  URL:=http://mercurial.selenic.com/
   SUBMENU:=Version Control Systems
 endef