[packages] mercurial: update to 1.8.4, refresh patches
[openwrt/svn-archive/archive.git] / net / mercurial / Makefile
index b1bd42d41152ae3fb54084f9025a8b1ad7933398..a94b7583cd0436ea54b01ec9fa925fd608e75ceb 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006,2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mercurial
-PKG_VERSION:=1.1.2
+PKG_VERSION:=1.8.4
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=http://selenic.com/mercurial/release/
-PKG_SOURCE:=mercurial-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=4fd3b9a2e5dcd025840c3849b136bec8
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mercurial.selenic.com/release
+PKG_MD5SUM:=b3dcc3de473e003dd1cc0500dcd9de47
+
 PKG_BUILD_DEPENDS:=python-mini
 
 include $(INCLUDE_DIR)/package.mk
@@ -22,14 +23,15 @@ $(call include_mk, python-package.mk)
 define Package/mercurial
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=python
+  DEPENDS:=+python
   TITLE:=Mercurial Source Control Management (SCM) system
-  URL:=http://www.selenic.com/mercurial/
+  URL:=http://mercurial.selenic.com/
   SUBMENU:=Version Control Systems
 endef
 
 define Package/mercurial/description
-  A fast, lightweight Source Control Management system designed for efficient handling of very large distributed projects.
+  A fast, lightweight Source Control Management system designed for efficient
+  handling of very large distributed projects.
 endef
 
 define Build/Compile
@@ -41,8 +43,8 @@ endef
 define Package/mercurial/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/bin $(1)/usr
-       $(CP) $(PKG_INSTALL_DIR)/lib $(1)/usr
+       $(CP) $(PKG_INSTALL_DIR)/bin $(1)/usr/
+       $(CP) $(PKG_INSTALL_DIR)/lib $(1)/usr/
 endef
 
 $(eval $(call BuildPackage,mercurial))