Add gw6c and make it link against uclibcxx (#2125)
[openwrt/svn-archive/archive.git] / net / miau / Makefile
index e7ab078f05c803789c6bfbd3e639ab392ed8ff20..192b0443f780a601f79d0c14c434e220cdb9c4f1 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miau
-PKG_VERSION:=0.6.4
-PKG_RELEASE:=2
+PKG_VERSION:=0.6.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/miau
-PKG_MD5SUM:=6ee1b23fe55b46988d0714021b0ff76c
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=cbce4182d66430a965a5fff26738ce3f
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,14 +23,16 @@ define Package/miau
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Another IRC-bouncer/proxy
-  DESCRIPTION:=\
-       In short, miau is an IRC-bouncer/proxy.\\\
-       Being more verbose, miau is small but quite featured \\\
-       IRC-bouncer - a service bit like HTTP-proxy, but \\\
-       for IRC-networks.
   URL:=http://sourceforge.net/projects/miau/
 endef
 
+define Package/miau/description
+       In short, miau is an IRC-bouncer/proxy.
+       Being more verbose, miau is small but quite featured 
+       IRC-bouncer - a service bit like HTTP-proxy, but 
+       for IRC-networks.
+endef
+
 CONFIGURE_ARGS += \
        --enable-automode \
        --enable-releasenick \
@@ -48,7 +46,7 @@ MAKE_FLAGS += \
 
 define Package/miau/install    
        $(INSTALL_DIR) $(1)/usr/bin     
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/default
        $(INSTALL_DIR) $(1)/etc/miau