Fix/clean several hundred package makefiles
[openwrt/svn-archive/archive.git] / net / miau / Makefile
index b14efc17c81859a0dc764016e3fda4c17c04f7c9..3afa9de2eaaea76ed5b4113e18f41255b49c6744 100644 (file)
@@ -44,12 +44,7 @@ endef
 
 
 define Build/Compile   
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC=$(TARGET_CC) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               install
+  $(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" install)
 endef
 
 define Package/miau/install