remove asterisk 1.2 because of build breakages and obsolescence
[openwrt/svn-archive/archive.git] / net / miax / Makefile
index 200dd04a970e7ca99dcf4e47382342f59be91b6e..2511bc5e97461e6ed17e4d3369fd5c21e6459ad4 100644 (file)
@@ -11,25 +11,27 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=miax
 PKG_VERSION:=1.4
 PKG_RELEASE:=1
-PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
 
-PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://mesh.dl.sourceforge.net/sourceforge/miax/
+PKG_MD5SUM:=44f0d2ef46ee2697d890b7b96846adc7
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/miax
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=+libpthread +bluez-libs
- TITLE:=A console iax (asterisk) client
- DESCRIPTION:=miax is a console iax (asterisk) client, it can work with\\\
-a soundcard as a normal voip phone, taking input/output from\\\
-keyboard, analog/gsm/isdn modem or bluetooth phones.\\\
- URL:=http://www.eja.it/?l=gpl&testo=miax
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread +bluez-libs
+  TITLE:=A console iax (asterisk) client
+  URL:=http://www.eja.it/?l=gpl&testo=miax
+endef
+
+define Package/miax/description
+       miax is a console iax (asterisk) client, it can work with 
+       a soundcard as a normal voip phone, taking input/output from 
+       keyboard, analog/gsm/isdn modem or bluetooth phones.
 endef
 
 define Build/Compile
@@ -42,8 +44,8 @@ define Build/Compile
 endef
 
 define Package/miax/install    
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/miax $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/miax $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,miax))