asterisk: no reason to download sounds on each build
[openwrt/svn-archive/archive.git] / net / miniupnpd / Makefile
index c19342faca8230ccd63f9a25e45bdeed9e825a82..0a2d443e981f2c81181b88f7956aa5051597be79 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,9 +9,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.5.20110302
+PKG_VERSION:=1.5.20110309
 PKG_RELEASE:=2
-PKG_MD5SUM:=9c2906a2f87d9b9504e4fc09488afe41
+PKG_MD5SUM:=350d20bf25922e12f8d69e06fa33fd83
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/miniupnpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables
+  DEPENDS:=+iptables +libip4tc
   TITLE:=Lightweight UPnP daemon
   SUBMENU:=Firewall
   URL:=http://miniupnp.free.fr/
@@ -40,7 +40,7 @@ define Build/Compile
                CC="$(TARGET_CC)" \
                TARGET_OPENWRT=1 \
                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(firstword $(wildcard $(KERNEL_BUILD_DIR)/iptables-*/include)) -DIPTABLES_143" \
-               LIBS="$(STAGING_DIR)/usr/lib/libiptc.so $(STAGING_DIR)/usr/lib/libip4tc.so $(STAGING_DIR)/usr/lib/libip6tc.so"
+               LIBS="$(STAGING_DIR)/usr/lib/libip4tc.so"
 endef
 
 define Package/miniupnpd/install
@@ -51,7 +51,6 @@ define Package/miniupnpd/install
        $(INSTALL_DATA) ./files/miniupnpd.iface.hotplug $(1)/etc/hotplug.d/iface/50-miniupnpd
        $(INSTALL_DATA) ./files/miniupnpd.firewall.hotplug $(1)/etc/hotplug.d/firewall/50-miniupnpd
        $(INSTALL_DIR) $(1)/usr/share/miniupnpd
-       $(INSTALL_DATA) ./files/upnpd.config.example $(1)/etc/config/upnpd.example
 endef
 
 $(eval $(call BuildPackage,miniupnpd))