[package] update faifa to r55, patch from Raphael Huck.
[openwrt/svn-archive/archive.git] / net / mtr / Makefile
index cfd7f46596a2824df49fd76241d7e22282191ff9..06940e3efb2b5af90f0b8619900e41bdfad67268 100644 (file)
@@ -4,21 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.75
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
-PKG_CAT:=zcat
+PKG_MD5SUM:=23baca52d0922c2ecba7eba05317868c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,18 +24,20 @@ define Package/mtr
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=Full screen ncurses traceroute tool
-  DESCRIPTION:=\
-       mtr combines the functionality of the 'traceroute' and 'ping' programs \\\
-       in a single network diagnostic tool.\\\
-       As mtr starts, it investigates the network connection between the host \\\
-       mtr runs on and a user-specified destination host.  After it \\\
-       determines the address of each network hop between the machines, \\\
-       it sends a sequence ICMP ECHO requests to each one to determine the \\\
-       quality of the link to each machine.  As it does this, it prints \\\
-       running statistics about each machine.
   URL:=http://www.bitwizard.nl/mtr/
 endef
 
+define Package/mtr/description
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
+       in a single network diagnostic tool.
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
+       running statistics about each machine.
+endef
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -56,15 +55,9 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
-define Package/mtr/install     
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
+define Package/mtr/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,mtr))