[packages] tor-alpha: update to 0.2.2.22-alpha, add archive mirror
[openwrt/svn-archive/archive.git] / net / mtr / Makefile
index 9da915ed4e2356c083a9825b92c538e76d013c73..41fb068e8652cb7aaa62999e0345a68fc8214219 100644 (file)
@@ -1,23 +1,21 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.80
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
+PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr
+PKG_MD5SUM:=fa68528eaec1757f52bacf9fea8c68a9
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,16 +28,22 @@ define Package/mtr
 endef
 
 define Package/mtr/description
-       mtr combines the functionality of the 'traceroute' and 'ping' programs 
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
        in a single network diagnostic tool.
-       As mtr starts, it investigates the network connection between the host 
-       mtr runs on and a user-specified destination host. After it 
-       determines the address of each network hop between the machines, 
-       it sends a sequence ICMP ECHO requests to each one to determine the 
-       quality of the link to each machine. As it does this, it prints 
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
        running statistics about each machine.
 endef
 
+CONFIGURE_ARGS += \
+       --without-gtk \
+
+CONFIGURE_VARS += \
+       ac_cv_lib_resolv_res_mkquery=yes \
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -50,20 +54,10 @@ define Build/Configure
                config.h.in \
                configure \
        );
-       $(call Build/Configure/Default, \
-               --without-gtk \
-               , \
-               ac_cv_lib_resolv_res_mkquery=yes \
-       )
-endef
-
-define Build/Compile   
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(call Build/Configure/Default)
 endef
 
-define Package/mtr/install     
+define Package/mtr/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
 endef