Update mtr to 0.73 (#3633)
[openwrt/svn-archive/archive.git] / net / mtr / Makefile
index c5547c63971bcb71d6224977fecdc9d64c44080d..874947d81c09edbbd62eefcfdca87ad02fff616f 100644 (file)
@@ -9,16 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.69
+PKG_VERSION:=0.73
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr/
-PKG_MD5SUM:=58904d6d8d70114195cdeb653d56914c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=52223cc34c72092a0392865356a3dc76
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,18 +23,20 @@ define Package/mtr
   CATEGORY:=Network
   DEPENDS:=+libncurses
   TITLE:=Full screen ncurses traceroute tool
-  DESCRIPTION:=\
-       mtr combines the functionality of the 'traceroute' and 'ping' programs \\\
-       in a single network diagnostic tool.\\\
-       As mtr starts, it investigates the network connection between the host \\\
-       mtr runs on and a user-specified destination host.  After it \\\
-       determines the address of each network hop between the machines, \\\
-       it sends a sequence ICMP ECHO requests to each one to determine the \\\
-       quality of the link to each machine.  As it does this, it prints \\\
-       running statistics about each machine.
   URL:=http://www.bitwizard.nl/mtr/
 endef
 
+define Package/mtr/description
+       mtr combines the functionality of the 'traceroute' and 'ping' programs
+       in a single network diagnostic tool.
+       As mtr starts, it investigates the network connection between the host
+       mtr runs on and a user-specified destination host. After it
+       determines the address of each network hop between the machines,
+       it sends a sequence ICMP ECHO requests to each one to determine the
+       quality of the link to each machine. As it does this, it prints
+       running statistics about each machine.
+endef
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); touch \
                configure.in \
@@ -64,7 +62,7 @@ endef
 
 define Package/mtr/install     
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/mtr $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,mtr))