Update nagios-plugins to 1.4.12 (#3635)
[openwrt/svn-archive/archive.git] / net / nagios-plugins / Makefile
index ae2948a337936b766b225f286acb1cc83c33bdff..1c919bfcb1d5832768d3d508b9033edf6f12bdf5 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios-plugins
-PKG_VERSION:=1.4.11
+PKG_VERSION:=1.4.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagiosplug
-PKG_MD5SUM:=042783a2180a6987e0b403870b3d01f7
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=af68d00bbe2c39de02803d23e5eecca3
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,32 +23,28 @@ comma:= ,
 define Package/nagios-plugins
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Monitoring
   DEPENDS:=+uclibcxx
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-mysql \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-ping-command="/bin/ping -c %d %s" \
-               --with-ps-command="/bin/ps -Aopid" \
-               --with-ps-cols="6" \
-               --with-ps-format="%d %s %d %s %s %n" \
-               --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
-               --with-uptime-command="/usr/bin/uptime" \
-               --with-ssh-command="/usr/bin/ssh" \
-               --with-nslookup-command="/usr/bin/nslookup" \
-               , \
-       )
-endef
+CONFIGURE_ARGS += \
+       --without-mysql \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-ping-command="/bin/ping -c %d %s" \
+       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-cols="6" \
+       --with-ps-format="%d %s %d %s %s %n" \
+       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-uptime-command="/usr/bin/uptime" \
+       --with-ssh-command="/usr/bin/ssh" \
+       --with-nslookup-command="/usr/bin/nslookup"
 
 define Build/Compile
-       $(call Build/Compile/Default,\
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Package/nagios-plugins/install