[net] Monitoring: Finally collected a Nagios programs under Monitoring submenu.
[openwrt/svn-archive/archive.git] / net / nagios-plugins / Makefile
index 0970444903c1b68264ff79c9c05a6dd3a49caa89..68490810ebe35bf48bd3f0396cef25bdcf974da8 100644 (file)
@@ -1,55 +1,48 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios-plugins
-PKG_VERSION:=1.4.6
-PKG_RELEASE:=1
+PKG_VERSION:=1.4.14
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagiosplug
-PKG_MD5SUM:=ea79fa91092d709aa6b2e732b1d55541
-PKG_CAT:=zcat
+PKG_MD5SUM:=a1835a48a777863ed2583de3c82446a9
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP:=libtool no-autoreconf
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+comma:= ,
+
 define Package/nagios-plugins
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=uclibcxx
+  SUBMENU:=Monitoring
+  DEPENDS:=+uclibcxx +libpq
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-mysql \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-ping-command="/bin/ping -c %d %s" \
-               --with-ps-command="/bin/ps -Aopid" \
-               --with-ps-cols="5" \
-               --with-ps-format="%d %s %d %s %n" \
-               --with-uptime-command="/usr/bin/uptime" \
-               --with-ssh-command="/usr/bin/ssh" \
-               --with-nslookup-command="/usr/bin/nslookup" \
-               , \
-       )
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default,\
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
-endef
+CONFIGURE_ARGS += \
+       --without-mysql \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-ping-command="/bin/ping -w %d -c %d %s" \
+       --with-ping6-command="/bin/ping6 -w %d -c %d %s" \
+       --with-ps-command="/bin/ps -Aopid" \
+       --with-ps-cols="6" \
+       --with-ps-format="%d %s %d %s %s %n" \
+       --with-ps-varlist="&procuid$(comma)&procpid$(comma)&procvsz$(comma)procstat$(comma)procprog$(comma)&pos" \
+       --with-uptime-command="/usr/bin/uptime" \
+       --with-ssh-command="/usr/bin/ssh" \
+       --with-nslookup-command="/usr/bin/nslookup"
 
 define Package/nagios-plugins/install
        $(INSTALL_DIR) $(1)/usr/libexec/nagios