[packages] nagios-plugins: fix segfault in check_ping command (closes: #5015)
[openwrt/svn-archive/archive.git] / net / nagios-plugins / Makefile
index 5ef65c714a20471cd8d8f0bcaa8adc4205ecf1ed..7f76452983bee660c0182e0a4fe14af084fbba6b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nagios-plugins
 PKG_VERSION:=1.4.12
-PKG_RELEASE:=1
+PKG_RELEASE:=1.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagiosplug
@@ -32,7 +32,8 @@ endef
 CONFIGURE_ARGS += \
        --without-mysql \
        --with-openssl="$(STAGING_DIR)/usr" \
-       --with-ping-command="/bin/ping -c %d %s" \
+       --with-ping-command="/bin/ping -w %d -c %d %s" \
+       --with-ping6-command="/bin/ping6 -w %d -c %d %s" \
        --with-ps-command="/bin/ps -Aopid" \
        --with-ps-cols="6" \
        --with-ps-format="%d %s %d %s %s %n" \