[packages] Use default templates instead of custom reimplementations where applicable
[openwrt/svn-archive/archive.git] / net / nagios-plugins / Makefile
index 57890433fb55fff88f55c1f80c57a87d39389592..e0a7c84ee5b9d2dba290e4a12063451a474ab249 100644 (file)
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagiosplug
 PKG_MD5SUM:=a1835a48a777863ed2583de3c82446a9
 
+PKG_INSTALL:=1
+
 include $(INCLUDE_DIR)/package.mk
 
 comma:= ,
@@ -41,12 +43,6 @@ CONFIGURE_ARGS += \
        --with-ssh-command="/usr/bin/ssh" \
        --with-nslookup-command="/usr/bin/nslookup"
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
-
 define Package/nagios-plugins/install
        $(INSTALL_DIR) $(1)/usr/libexec/nagios
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/libexec/nagios/