[Packages] net/wifidog:
[openwrt/svn-archive/archive.git] / net / nagios / Makefile
index 7f4a8c598715d8ced45360cb003ea3a25995d3d0..6fa176571ea950e0d016e6424c22e0ba48cadb13 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -15,30 +15,37 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
 PKG_MD5SUM:=b6e3a21c91edb063c00712c6001e15ec
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
+PKG_BUILD_DEPENDS:=libnotimpl
+
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libpthread +microperl
   TITLE:=service and network monitoring program
-  DESCRIPTION:=\
-       service and network monitoring program
   URL:=http://www.nagios.org/
 endef
 
+define Package/nagios/description
+       service and network monitoring program
+endef
+
 define Package/send-nagios/conffiles
 /etc/send_nagios.cfg
 endef
 
+EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+
 define Build/Configure
        $(call Build/Configure/Default,\
                --with-nagios-user="root" \
-               --with-nagios-group="root" \
+               --with-nagios-group="root", \
+               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
+               LIBS="-lnotimpl" \
        )
 endef