stop nfsd and sshd on reboot (thx, puchu)
[openwrt/svn-archive/archive.git] / net / nagios / Makefile
index 989a9668380b081103f3eade769c2330b4797e44..734caf6f1cf832d2f263af5afcd5a328e8a60daf 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,12 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/nagios
 PKG_MD5SUM:=8c3a29e138f2ff8c8abbd3dd8a40c4b6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
 include $(INCLUDE_DIR)/package.mk
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
@@ -34,7 +30,7 @@ define Package/nagios/description
        service and network monitoring program
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS += \
        --with-nagios-user="root" \
@@ -44,9 +40,6 @@ CONFIGURE_ARGS += \
        --without-gd-inc \
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)"
        
-CONFIGURE_VARS += \
-       LIBS="-lnotimpl"
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \