[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / nagios / Makefile
index 6a98d584dc66785237f4e5341eb13836afa02219..b9907b37ad75eaecc0bc96b62a3ac748b7202728 100644 (file)
@@ -1,10 +1,9 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -20,8 +19,6 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
-PKG_BUILD_DEPENDS:=libnotimpl
-
 define Package/nagios
   SECTION:=net
   CATEGORY:=Network
@@ -35,7 +32,7 @@ define Package/nagios/description
        service and network monitoring program
 endef
 
-EXTRA_CFLAGS += -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS += \
        --with-nagios-user="root" \
@@ -45,13 +42,11 @@ CONFIGURE_ARGS += \
        --without-gd-inc \
        CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)"
        
-CONFIGURE_VARS += \
-       LIBS="-lnotimpl"
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL_OPTS="" \
+               STRIP=: \
                all install install-config
 endef