[packages] massive change: replace occurences of -I$(STAGING_DIR)/{include,usr/includ...
[openwrt/svn-archive/archive.git] / net / nbd / Makefile
index c7d70345a5a5f7788d0bea8d8c56de76b4eaff68..431e57bd522a6a6586d905ae9d73d1cb689ff134 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $ 
 
 include $(TOPDIR)/rules.mk
 
@@ -23,6 +22,7 @@ PKG_BUILD_DEPENDS:=glib2 libintl
 define Package/nbd
   SECTION:=net
   CATEGORY:=Network
+  DEPENDS:=@LINUX_2_6
   TITLE:=Network Block Device utilities
   URL:=http://nbd.sourceforge.net
 endef
@@ -39,7 +39,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/" \
+               CPPFLAGS="$(TARGET_CPPFLAGS) -L$(STAGING_DIR)/usr/lib/libintl/lib/ $(TARGET_LDFLAGS)" \
                nbd-client
 endef