port snort to -ng
[openwrt/svn-archive/archive.git] / net / netperf / Makefile
index 2f623f1b76ec1b873e8770b807756d1a9ca7a8e2..9ca3a1ecc4076e4323a6c6e36ca47f61ae987ec5 100644 (file)
@@ -11,11 +11,11 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=netperf
 PKG_VERSION:=2.3pl1
 PKG_RELEASE:=1
-PKG_MD5SUM:=b74314d78af31cb13516fb9a372d2e86
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.netperf.org/netperf/archive/ \
        ftp://ftp.cup.hp.com/dist/networking/benchmarks/netperf/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=b74314d78af31cb13516fb9a372d2e86
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,22 +26,21 @@ define Package/netperf
   SECTION:=net
   CATEGORY:=Network
   TITLE:=network performance measurement tool
-  DESCRIPTION:=Program and service to do network performance measurement.
   URL:=http://www.netperf.org
 endef
 
 define Build/Compile   
        $(MAKE) -C $(PKG_BUILD_DIR) \
-           TARGET_NETPERF_HOME="/etc/netperf.conf" \
-           TARGET_CC=$(TARGET_CROSS)gcc \
-           TARGET_CFLAGS="$(TARGET_CFLAGS)" \
+               TARGET_NETPERF_HOME="/etc/netperf.conf" \
+               TARGET_CC="$(TARGET_CROSS)gcc" \
+               TARGET_CFLAGS="$(TARGET_CFLAGS)" \
                TARGET_LIBS="" \
                all
 endef
 
 define Package/netperf/install 
        install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/netserver.init $(1)/etc/init.d/S51netserver
+       install -m0755 ./files/netserver.init $(1)/etc/init.d/netserver
        install -d -m0755 $(1)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/netperf $(1)/usr/bin/
        install -m0755 $(PKG_BUILD_DIR)/netserver $(1)/usr/bin/