replace lots of manual install commands with INSTALL_* variables
[openwrt/svn-archive/archive.git] / net / nfs-kernel-server / Makefile
index cae589f6799de87da65adc1f17a1ad279152a147..e5c125d5c9ea721181f8de92dc5808b55fd06279 100644 (file)
@@ -1,4 +1,4 @@
-# $Id: Makefile 4033 2006-06-21 02:32:39Z nbd $
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 
 include $(TOPDIR)/rules.mk
 
@@ -40,10 +40,12 @@ define Package/nfs-kernel-server/conffiles
 endef
 
 define Build/Configure
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-static --enable-shared --disable-nfsv4 \
---disable-gss,ac_cv_func_malloc_0_nonnull=yes \
-ac_cv_func_memcmp_working=yes \
-ac_cv_func_setvbuf_reversed=no)
+       $(call Build/Configure/Default, \
+               --enable-static \
+               --enable-shared \
+               --disable-nfsv4 \
+               --disable-gss \
+       )
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
@@ -53,20 +55,20 @@ define Build/Compile
 endef
 
 define Package/nfs-kernel-server/install
 endef
 
 define Package/nfs-kernel-server/install
-       install -d -m755 $(1)/etc/init.d $(1)/usr/sbin
-       install -m0644 ./files/nfsd.exports $(1)/etc/exports
-       install -m0755 ./files/nfsd.init $(1)/etc/init.d/S60nfsd
-       install -m0755 $(PKG_BUILD_DIR)/utils/lockd/lockd $(1)/usr/sbin/rpc.lockd
-       install -m0755 $(PKG_BUILD_DIR)/utils/statd/statd $(1)/usr/sbin/rpc.statd
-       install -m0755 $(PKG_BUILD_DIR)/utils/nfsd/nfsd $(1)/usr/sbin/rpc.nfsd
-       install -m0755 $(PKG_BUILD_DIR)/utils/mountd/mountd $(1)/usr/sbin/rpc.mountd
-       install -m0755 $(PKG_BUILD_DIR)/utils/exportfs/exportfs $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d $(1)/usr/sbin
+       $(INSTALL_DATA) ./files/nfsd.exports $(1)/etc/exports
+       $(INSTALL_BIN) ./files/nfsd.init $(1)/etc/init.d/nfsd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/lockd/lockd $(1)/usr/sbin/rpc.lockd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/statd/statd $(1)/usr/sbin/rpc.statd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/nfsd/nfsd $(1)/usr/sbin/rpc.nfsd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/mountd/mountd $(1)/usr/sbin/rpc.mountd
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/exportfs/exportfs $(1)/usr/sbin/
 endef
 
 define Package/nfs-kernel-server-utils/install
 endef
 
 define Package/nfs-kernel-server-utils/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/utils/showmount/showmount $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/utils/nfsstat/nfsstat $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/showmount/showmount $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/utils/nfsstat/nfsstat $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,nfs-kernel-server))
 endef
 
 $(eval $(call BuildPackage,nfs-kernel-server))